Back
Maintenance

Updating system

Completed 19 May at 12:03am CEST.

Backend Frontend
Completed

We successfully updated the system, all services should work like before :)

Posted 19 May at 12:03am CEST.
Started

Updating the system.

Posted 18 May at 11:30pm CEST.